Home /Codeingnator /Message: Declaration of MX_Loader::helpers($helpers) should be compatible with ITF_Loader::helpers($helpers = Array) in CI

Message: Declaration of MX_Loader::helpers($helpers) should be compatible with ITF_Loader::helpers($helpers = Array) in CI

While get error after upgrading php 7

We have to change in files

  1. /system/core/Loader.php
  2. /system/core/Lang.php

//function load($langfile = ”, $idiom = ”, $return = FALSE, $add_suffix = TRUE, $alt_path = ”)
function load($langfile, $idiom, $return = FALSE, $add_suffix = TRUE, $alt_path)

Just remove by default variable see the above line in both files it will work.

Leave a Reply